You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/xss-sanitize/xss-sanitize-0.3.6.ebuild

32 lines
1.1 KiB

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.7.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="sanitize untrusted HTML to prevent XSS attacks"
HOMEPAGE="https://github.com/yesodweb/haskell-xss-sanitize#readme"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0/${PV}"
KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
RDEPEND=">=dev-haskell/attoparsec-0.10.0.3:=[profile?] <dev-haskell/attoparsec-1:=[profile?]
>=dev-haskell/css-text-0.1.1:=[profile?] <dev-haskell/css-text-0.2:=[profile?]
>=dev-haskell/network-uri-2.6:=[profile?]
>=dev-haskell/tagsoup-0.12.2:=[profile?] <dev-haskell/tagsoup-1:=[profile?]
>=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-2:=[profile?]
>=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
>=dev-lang/ghc-8.4.3:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-2.2.0.1
test? ( >=dev-haskell/hspec-1.3
>=dev-haskell/hunit-1.2 )
"