You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/yesod-form/yesod-form-1.7.4.ebuild

46 lines
1.4 KiB

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.8.0.0.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Form handling support for Yesod Web Framework"
HOMEPAGE="https://www.yesodweb.com/"
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
IUSE="+network-uri"
RDEPEND="dev-haskell/aeson:=[profile?]
>=dev-haskell/attoparsec-0.10:=[profile?]
>=dev-haskell/blaze-builder-0.2.1.4:=[profile?]
>=dev-haskell/blaze-html-0.5:=[profile?]
>=dev-haskell/blaze-markup-0.5.1:=[profile?]
dev-haskell/byteable:=[profile?]
dev-haskell/data-default:=[profile?]
>=dev-haskell/email-validate-1.0:=[profile?]
dev-haskell/persistent:=[profile?]
dev-haskell/resourcet:=[profile?]
>=dev-haskell/shakespeare-2.0:=[profile?]
>=dev-haskell/wai-1.3:=[profile?]
>=dev-haskell/xss-sanitize-0.3.0.1:=[profile?]
>=dev-haskell/yesod-core-1.6:=[profile?] <dev-haskell/yesod-core-1.7:=[profile?]
>=dev-haskell/yesod-persistent-1.6:=[profile?] <dev-haskell/yesod-persistent-1.7:=[profile?]
>=dev-lang/ghc-8.4.3:=
network-uri? ( >=dev-haskell/network-uri-2.6:=[profile?] )
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-2.2.0.1
test? ( dev-haskell/hspec )
"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag network-uri network-uri)
}