You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-lang/execline/execline-2.9.4.0.ebuild

52 lines
1.1 KiB

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit optfeature toolchain-funcs
DESCRIPTION="A non-interactive scripting language"
HOMEPAGE="https://www.skarnet.org/software/execline/"
SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
LICENSE="ISC"
SLOT="0/$(ver_cut 1-2).4"
KEYWORDS="~alpha amd64 arm ~mips ~riscv x86"
RDEPEND=">=dev-libs/skalibs-2.14.0.0:="
DEPEND="${RDEPEND}"
HTML_DOCS=( doc/. )
src_prepare() {
default
# Avoid QA warning for LDFLAGS addition
sed -i -e 's/.*-Wl,--hash-style=both$/:/' configure || die
sed -i -e '/AR := /d' -e '/RANLIB := /d' Makefile || die
}
src_configure() {
tc-export AR CC RANLIB
local myconf=(
--bindir=/bin
--dynlibdir="/$(get_libdir)"
--libdir="/usr/$(get_libdir)/${PN}"
--with-dynlib="/$(get_libdir)"
--with-lib="/usr/$(get_libdir)/skalibs"
--with-sysdeps="/usr/$(get_libdir)/skalibs"
--enable-shared
--disable-allstatic
--disable-static
--disable-static-libc
)
econf "${myconf[@]}"
}
pkg_postinst() {
optfeature "man pages" app-doc/execline-man-pages
}