You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-lang/pcc/pcc-1.1.0-r1.ebuild

34 lines
644 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit autotools flag-o-matic
DESCRIPTION="pcc portable c compiler"
HOMEPAGE="http://pcc.ludd.ltu.se"
SRC_URI="ftp://pcc.ludd.ltu.se/pub/pcc-releases/${P}.tgz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
DEPEND=">=dev-libs/pcc-libs-${PV}"
RDEPEND="${DEPEND}"
PATCHES=( "${FILESDIR}"/${P}-multiarch.patch )
src_prepare() {
default
sed -i \
-e 's/AC_CHECK_PROG(strip,strip,yes,no)//' \
-e 's/AC_SUBST(strip)//' configure.ac || die
eautoreconf
}
src_configure() {
append-cflags -fcommon
econf --disable-stripping
}