You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-lang/srf/srf-1.0-r2.ebuild

35 lines
650 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit vcs-clean
DESCRIPTION="The Simple Recursive Functions programming language"
HOMEPAGE="http://www.stratigery.com/srf.html"
SRC_URI="http://www.stratigery.com/srf.html/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~x86-linux ~ppc-macos"
DEPEND="
app-alternatives/lex
app-alternatives/yacc"
PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
src_prepare() {
default
# Remove CVS directory Bug#371821
ecvs_clean
}
src_install() {
dobin srf rfunc/rfunc
doman srf.1
dodoc README srf.html
dodoc -r examples
}