You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/aws-c-common/aws-c-common-0.5.2.ebuild

30 lines
613 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit cmake
DESCRIPTION="Core c99 package for AWS SDK for C"
HOMEPAGE="https://github.com/awslabs/aws-c-common"
SRC_URI="https://github.com/awslabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="static-libs test"
RESTRICT="!test? ( test )"
PATCHES=(
"${FILESDIR}"/${P}-remove-Werror-CFLAG.patch
)
src_configure() {
local mycmakeargs=(
-DBUILD_SHARED_LIBS=$(usex !static-libs)
-DBUILD_TESTING=$(usex test)
)
cmake_src_configure
}