You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/bcm2835/bcm2835-1.71.ebuild

31 lines
635 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit toolchain-funcs
DESCRIPTION="Provides access to GPIO and other IO functions on the Broadcom BCM2835"
HOMEPAGE="https://www.airspayce.com/mikem/bcm2835/"
SRC_URI="https://www.airspayce.com/mikem/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~arm"
IUSE="doc examples"
BDEPEND="doc? ( app-text/doxygen )"
src_compile() {
emake AR="$(tc-getAR)"
}
src_install() {
use doc && HTML_DOCS=( doc/html/. )
if use examples; then
dodoc -r examples
docompress -x /usr/share/doc/${PF}/examples
fi
default
}