You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/cgilib/cgilib-0.7-r1.ebuild

27 lines
609 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit autotools
DESCRIPTION="A simple and lightweight interface to the CGI for C and C++ programs"
HOMEPAGE="https://www.infodrom.org/projects/cgilib/"
SRC_URI="https://www.infodrom.org/projects/cgilib/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86"
IUSE="static-libs"
DOCS=( AUTHORS ChangeLog README cookies.txt )
src_prepare() {
default
eautoreconf
}
src_configure() {
econf \
$(use_enable static-libs static)
}