You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/hyprland-protocols/hyprland-protocols-9999.ebuild

26 lines
536 B

# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit meson
DESCRIPTION="Wayland protocol extensions for Hyprland"
HOMEPAGE="https://github.com/hyprwm/hyprland-protocols"
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/hyprwm/${PN}.git"
inherit git-r3
else
SRC_URI="https://github.com/hyprwm/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
KEYWORDS="amd64 ~riscv"
fi
LICENSE="BSD"
SLOT="0"
BDEPEND="
dev-util/wayland-scanner
virtual/pkgconfig
"