You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/igraph/igraph-0.10.4-r1.ebuild

55 lines
1.1 KiB

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit cmake flag-o-matic
DESCRIPTION="Creating and manipulating undirected and directed graphs"
HOMEPAGE="https://igraph.org/"
SRC_URI="https://github.com/igraph/igraph/releases/download/${PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0/0"
KEYWORDS="amd64 x86"
IUSE="debug test threads"
RESTRICT="!test? ( test )"
RDEPEND="
dev-libs/gmp:0=
dev-libs/libxml2
sci-libs/arpack
sci-mathematics/glpk:=
sci-mathematics/plfit
virtual/blas
virtual/lapack"
DEPEND="${RDEPEND}"
src_configure() {
# -Werror=strict-aliasing
#
# Fixed in upstream git master.
append-flags -fno-strict-aliasing
filter-lto
local mycmakeargs=(
-DUSE_CCACHE=OFF
-DIGRAPH_GLPK_SUPPORT=ON
-DIGRAPH_GRAPHML_SUPPORT=ON
-DIGRAPH_USE_INTERNAL_ARPACK=OFF
-DIGRAPH_USE_INTERNAL_BLAS=OFF
-DIGRAPH_USE_INTERNAL_GLPK=OFF
-DIGRAPH_USE_INTERNAL_GMP=OFF
-DIGRAPH_USE_INTERNAL_LAPACK=OFF
-DIGRAPH_USE_INTERNAL_PLFIT=OFF
-DIGRAPH_ENABLE_TLS=$(usex threads)
-DBUILD_TESTING=$(usex test)
)
cmake_src_configure
}
src_test() {
cmake_build check
}