You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/intel-metrics-library/intel-metrics-library-1.0.1...

28 lines
633 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
CMAKE_BUILD_TYPE="Release"
MY_PN="${PN/intel-/}"
MY_P="${MY_PN}-${PV}"
inherit cmake
DESCRIPTION="User mode driver helper library that provides access to GPU performance counters"
HOMEPAGE="https://github.com/intel/metrics-library"
SRC_URI="https://github.com/intel/${MY_PN}/archive/refs/tags/${MY_P}.tar.gz"
S="${WORKDIR}/${MY_PN}-${MY_P}"
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="amd64"
DEPEND="x11-libs/libdrm"
RDEPEND="${DEPEND}"
src_prepare() {
sed -e '/-Werror/d' -i CMakeLists.txt || die
cmake_src_prepare
}