You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/jansson/jansson-2.14-r1.ebuild

43 lines
854 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit toolchain-funcs
DESCRIPTION="C library for encoding, decoding and manipulating JSON data"
HOMEPAGE="https://www.digip.org/jansson/"
SRC_URI="https://github.com/akheron/jansson/releases/download/v${PV}/${P}.tar.bz2"
LICENSE="MIT"
SLOT="0/4"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
IUSE="doc static-libs"
BDEPEND="
sys-devel/binutils
doc? ( dev-python/sphinx )"
PATCHES=( "${FILESDIR}/${P}-test-symbols.patch" )
src_configure() {
tc-ld-force-bfd
econf $(use_enable static-libs static)
}
src_compile() {
default
if use doc ; then
emake html
HTML_DOCS=( doc/_build/html/. )
fi
}
src_install() {
default
find "${ED}" -name '*.la' -delete || die
}