You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/libkpass/libkpass-6-r2.ebuild

27 lines
585 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DESCRIPTION="Libkpass is a C implementation to access KeePass 1.x format password databases"
HOMEPAGE="https://sourceforge.net/projects/libkpass/"
SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64"
IUSE="static-libs"
RDEPEND=">=dev-libs/nettle-2.7.1:="
DEPEND="${RDEPEND}"
src_configure() {
econf $(use_enable static-libs static)
}
src_install() {
default
use static-libs || rm -f "${ED}"/usr/lib*/${PN}.la
}