You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/libusbhp/libusbhp-1.0.2-r1.ebuild

28 lines
522 B

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="USB Hotplug Library"
HOMEPAGE="http://www.aasimon.org/libusbhp/"
SRC_URI="http://www.aasimon.org/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~arm ~mips ~x86"
RDEPEND=">=virtual/libudev-147"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
src_configure() {
econf \
--disable-static \
--without-debug
}
src_install() {
default
find "${ED}" -name '*.la' -delete || die
}