You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/libvterm/libvterm-0.3.2.ebuild

43 lines
866 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit toolchain-funcs
DESCRIPTION="An abstract library implementation of a VT220/xterm/ECMA-48 terminal emulator"
HOMEPAGE="https://www.leonerd.org.uk/code/libvterm/"
SRC_URI="https://www.leonerd.org.uk/code/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~x64-macos"
BDEPEND="
dev-lang/perl
dev-build/libtool
"
src_compile() {
MYMAKEARGS=(
VERBOSE=1
PREFIX="${EPREFIX}"/usr
LIBDIR="${EPREFIX}/usr/$(get_libdir)"
CC="$(tc-getCC)"
)
emake "${MYMAKEARGS[@]}"
}
src_test() {
emake "${MYMAKEARGS[@]}" test
}
src_install() {
emake "${MYMAKEARGS[@]}" DESTDIR="${D}" install
find "${ED}" -name '*.la' -delete || die "Failed to prune libtool files"
find "${ED}" -name '*.a' -delete || die
}