You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/nsgenbind/nsgenbind-0.9.ebuild

32 lines
644 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit netsurf
DESCRIPTION="Generate Javascript-to-DOM bindings from w3c webidl files"
HOMEPAGE="http://www.netsurf-browser.org/"
SRC_URI="https://download.netsurf-browser.org/libs/releases/${P}-src.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
BDEPEND="
dev-build/netsurf-buildsystem
app-alternatives/yacc"
_emake() {
netsurf_define_makeconf
emake "${NETSURF_MAKECONF[@]}" COMPONENT_TYPE=binary $@
}
src_compile() {
_emake
}
src_install() {
_emake DESTDIR="${D}" install
}