You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/onigmo/onigmo-6.2.0-r1.ebuild

36 lines
726 B

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit autotools
DESCRIPTION="Onigmo is a regular expressions library forked from Oniguruma"
HOMEPAGE="https://github.com/k-takata/Onigmo"
SRC_URI="https://github.com/k-takata/${PN^o}/releases/download/${P^o}/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0/6"
KEYWORDS="amd64 x86"
IUSE="combination-explosion-check crnl-as-line-terminator"
src_prepare() {
default
eautoreconf
}
src_configure() {
econf \
$(use_enable combination-explosion-check) \
$(use_enable crnl-as-line-terminator)
}
src_install() {
default
dodoc doc/{API,FAQ,RE}{,.ja} doc/UnicodeProps.txt
find "${ED}" -name "*.la" -delete || die
}