You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/opencl-icd-loader/opencl-icd-loader-2023.12.1...

45 lines
953 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit cmake-multilib multibuild prefix
MY_PN="OpenCL-ICD-Loader"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Official Khronos OpenCL ICD Loader"
HOMEPAGE="https://github.com/KhronosGroup/OpenCL-ICD-Loader"
SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ppc64 ~riscv x86"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="!dev-libs/ocl-icd"
DEPEND="${RDEPEND}
>=dev-util/opencl-headers-${PV}"
S="${WORKDIR}/${MY_P}"
src_prepare() {
hprefixify loader/icd_platform.h
cmake_src_prepare
}
multilib_src_configure() {
local mycmakeargs=(
-DBUILD_TESTING=$(usex test)
)
cmake_src_configure
}
multilib_src_test() {
local -x OCL_ICD_FILENAMES="${BUILD_DIR}/test/driver_stub/libOpenCLDriverStub.so"
local -x OCL_ICD_VENDORS="/dev/null"
cmake_src_test
}