You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/rccl/rccl-5.1.3.ebuild

52 lines
1.1 KiB

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
ROCM_VERSION=${PV}
inherit cmake edo rocm
DESCRIPTION="ROCm Communication Collectives Library (RCCL)"
HOMEPAGE="https://github.com/ROCmSoftwarePlatform/rccl"
SRC_URI="https://github.com/ROCmSoftwarePlatform/rccl/archive/rocm-${PV}.tar.gz -> rccl-${PV}.tar.gz"
LICENSE="BSD"
KEYWORDS="~amd64"
SLOT="0/$(ver_cut 1-2)"
IUSE="test"
RDEPEND="dev-util/hip
dev-util/rocm-smi:${SLOT}"
DEPEND="${RDEPEND}"
BDEPEND=">=dev-build/cmake-3.22
>=dev-build/rocm-cmake-5.0.2-r1
test? ( dev-cpp/gtest )"
RESTRICT="!test? ( test )"
S="${WORKDIR}/rccl-rocm-${PV}"
PATCHES=(
"${FILESDIR}/${PN}-5.0.2-change_install_location.patch"
"${FILESDIR}/${PN}-5.1.3-remove-chrpath.patch"
)
src_configure() {
addpredict /dev/kfd
addpredict /dev/dri/
local mycmakeargs=(
-DSKIP_RPATH=On
-DAMDGPU_TARGETS="$(get_amdgpu_flags)"
-DBUILD_TESTS=$(usex test ON OFF)
-Wno-dev
)
CXX=hipcc cmake_src_configure
}
src_test() {
check_amdgpu
LD_LIBRARY_PATH="${BUILD_DIR}" edob test/UnitTests
}