You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/rremove/rremove-1.0.5.ebuild

23 lines
506 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="A simple library to recursively delete non-empty directories"
HOMEPAGE="https://frigidcode.com/code/rremove/"
SRC_URI="https://frigidcode.com/code/rremove/${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="static-libs"
src_configure() {
econf $(use_enable static-libs static)
}
src_install() {
default
use static-libs || find "${ED}" -name '*.la' -delete
}