You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/serd/serd-0.32.2.ebuild

48 lines
1.0 KiB

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit meson-multilib
DESCRIPTION="Library for RDF syntax which supports reading and writing Turtle and NTriples"
HOMEPAGE="https://drobilla.net/software/serd.html"
SRC_URI="https://download.drobilla.net/${P}.tar.xz"
LICENSE="ISC"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv sparc x86"
IUSE="doc test +tools"
RESTRICT="!test? ( test )"
BDEPEND="
doc? (
app-text/doxygen
dev-python/sphinx
dev-python/sphinx-lv2-theme
dev-python/sphinxygen
)
"
src_prepare() {
default
# fix doc installation path
sed -i "s/versioned_name/'${PF}'/g" doc/man/meson.build doc/html/meson.build doc/singlehtml/meson.build || die
}
multilib_src_configure() {
local emesonargs=(
$(meson_native_use_feature doc docs)
$(meson_feature test tests)
$(meson_feature tools)
)
meson_src_configure
}
multilib_src_install_all() {
local DOCS=( AUTHORS NEWS README.md )
einstalldocs
}