You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/sexpp/sexpp-0.8.6.ebuild

36 lines
721 B

# Copyright 2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit cmake
DESCRIPTION="S-expressions parser and generator library in C++"
HOMEPAGE="https://github.com/rnpgp/sexpp"
SRC_URI="https://github.com/rnpgp/sexpp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm64 ~loong ~ppc64 x86"
IUSE="cli test"
BDEPEND="virtual/pkgconfig
test? ( dev-cpp/gtest )"
RESTRICT="!test? ( test )"
src_configure() {
local mycmakeargs=(
-DBUILD_SHARED_LIBS=on
-DDOWNLOAD_GTEST=off
-DWITH_COVERAGE=off
-DWITH_SANITIZERS=off
-DWITH_SEXP_CLI=$(usex cli on off)
-DWITH_SEXP_TESTS=$(usex test on off)
)
cmake_src_configure
}