You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-lisp/c2ffi/c2ffi-17.0.0.20240314.ebuild

23 lines
569 B

# Copyright 2019-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
LLVM_MAX_SLOT=17
inherit cmake llvm
MY_COMMIT="164637979127b2f995930b352d06dea5e9572064"
DESCRIPTION="Clang-based FFI wrapper generator for Common Lisp"
HOMEPAGE="https://github.com/rpav/c2ffi"
SRC_URI="https://github.com/rpav/c2ffi/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/c2ffi-${MY_COMMIT}"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64"
DEPEND="sys-devel/clang:${LLVM_MAX_SLOT}
sys-devel/llvm:${LLVM_MAX_SLOT}"
RDEPEND="${DEPEND}"