You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-php/PEAR-Crypt_CHAP/PEAR-Crypt_CHAP-1.5.0-r3.eb...

31 lines
706 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit php-pear-r2
DESCRIPTION="Generating CHAP packets"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
# Crypt_CHAP_MSv1 needs mcrypt which is gone in 7.2+
RDEPEND="|| ( ( dev-php/pecl-mcrypt >=dev-lang/php-7.2:*[hash(+)] )
<dev-lang/php-7.2:*[crypt,hash]
)"
DEPEND="test? ( ${RDEPEND} dev-php/PEAR-PEAR )"
PATCHES=( "${FILESDIR}/CHAP-1.5.0-constructor.patch" )
src_install() {
php-pear-r2_src_install
insinto /usr/share/php/Crypt
doins CHAP.php
}
src_test() {
pear run-tests tests/Crypt_CHAP.phpt || die
}