You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-php/PEAR-DB/PEAR-DB-1.11.0.ebuild

28 lines
744 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit php-pear-r2
KEYWORDS="amd64 arm ~hppa ppc ppc64 ~s390 sparc x86"
DESCRIPTION="Database abstraction layer for PHP"
LICENSE="PHP-3"
SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
DEPEND="test? ( dev-php/PEAR-PEAR )"
DOCS=( doc/TESTERS doc/IDEAS doc/MAINTAINERS doc/STATUS )
src_test() {
# Requires the "pear" executable from dev-php/PEAR-PEAR, and also
# a working version of the cli SAPI eselected.
pear run-tests tests || die
# The command succeeds regardless of whether or not the test suite
# passed, but this file is only written when there was a failure.
[[ -f run-tests.log ]] && die "test suite failed"
}