You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-php/PEAR-Net_SmartIRC/PEAR-Net_SmartIRC-1.1.14.eb...

25 lines
524 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit php-pear-r2
DESCRIPTION="PHP class to communicate with IRC networks"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 ~hppa ppc ppc64 sparc x86"
IUSE="doc examples"
DOCS=( CREDITS FEATURES docs/HOWTO README.md )
src_install() {
local HTML_DOCS=( )
use examples && HTML_DOCS+=( docs/examples/ )
if use doc; then
DOCS+=( docs/DOCUMENTATION )
HTML_DOCS+=( docs/HTML/* )
fi
php-pear-r2_src_install
}