You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-php/PEAR-Validate/PEAR-Validate-0.8.6.ebuild

24 lines
552 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit php-pear-r2
KEYWORDS="amd64 ~arm ~hppa ppc ppc64 ~s390 sparc x86"
DESCRIPTION="Validation class"
LICENSE="BSD"
SLOT="0"
IUSE="minimal test"
RESTRICT="!test? ( test )"
DEPEND="test? ( dev-php/PEAR-PEAR dev-php/PEAR-Date )"
RDEPEND="!minimal? ( dev-php/PEAR-Date )"
#PATCHES=( "${FILESDIR}/0.8.5-fix-test-php7.patch" )
HTML_DOCS=( docs/Example_Locale.php docs/sample_multiple.php )
src_test() {
peardev run-tests tests || die
}