You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-php/PHP_Timer/PHP_Timer-5.0.3.ebuild

32 lines
752 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
MY_PN="php-timer"
DESCRIPTION="Utility class for timing"
HOMEPAGE="https://phpunit.de"
SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86"
IUSE=""
S="${WORKDIR}/${MY_PN}-${PV}"
RDEPEND="dev-php/fedora-autoloader
>=dev-lang/php-7.3:*"
src_install() {
insinto /usr/share/php/PHP/Timer
doins -r src/*
newins "${FILESDIR}/autoload-5.0.3.php" autoload.php
}
pkg_postinst() {
ewarn "This library now loads via /usr/share/php/PHP/Timer/autoload.php"
ewarn "Please update any scripts to require the autoloader"
}