You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-php/pecl-imagick/pecl-imagick-3.7.0-r2.ebuild

35 lines
912 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PHP_EXT_NAME="imagick"
USE_PHP="php8-1 php8-2"
# https://github.com/Imagick/imagick/issues/626
PHP_EXT_NEEDED_USE="-debug"
inherit php-ext-pecl-r3
KEYWORDS="amd64 ~arm ~arm64 x86"
DESCRIPTION="PHP wrapper for the ImageMagick library"
HOMEPAGE="https://pecl.php.net/package/imagick https://github.com/Imagick/imagick"
LICENSE="PHP-3.01"
SLOT="0"
IUSE="examples test"
RESTRICT="!test? ( test )"
# imagemagick[-openmp] is needed wrt bug 547922 and upstream
# https://github.com/Imagick/imagick#openmp
RDEPEND="media-gfx/imagemagick:=[-openmp]"
DEPEND="${RDEPEND}
test? ( media-gfx/imagemagick:=[hdri,jpeg,png,svg,truetype,xml] )"
PHP_EXT_ECONF_ARGS="--with-imagick=${EPREFIX}/usr"
src_install() {
php-ext-pecl-r3_src_install
php-ext-source-r3_addtoinifiles "imagick.skip_version_check" "1"
}