You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-php/pecl-mcrypt/pecl-mcrypt-1.0.5.ebuild

25 lines
526 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PHP_EXT_NAME="mcrypt"
USE_PHP="php8-1"
MY_P="${PN/pecl-/}-${PV/_rc/RC}"
PHP_EXT_ECONF_ARGS=()
PHP_EXT_PECL_FILENAME="${MY_P}.tgz"
PHP_EXT_S="${WORKDIR}/${MY_P}"
inherit php-ext-pecl-r3
DESCRIPTION="Bindings for the libmcrypt library"
LICENSE="PHP-3.01"
SLOT="0"
KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86"
DEPEND="dev-libs/libltdl
dev-libs/libmcrypt"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"