You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-php/sebastian-environment/sebastian-environment-5.1.3...

27 lines
660 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
MY_PN="${PN/sebastian-//}"
DESCRIPTION="Helps writing PHP code that has runtime-specific execution paths"
HOMEPAGE="https://phpunit.de"
SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 arm ~hppa ppc ppc64 ~s390 sparc x86"
IUSE=""
S="${WORKDIR}/${MY_PN}-${PV}"
RDEPEND="dev-php/fedora-autoloader
>=dev-lang/php-7.3:*"
src_install() {
insinto /usr/share/php/SebastianBergmann/Environment
doins -r src/*
newins "${FILESDIR}/autoload-4.2.3.php" autoload.php
}