You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/oslo-i18n/oslo-i18n-6.3.0.ebuild

36 lines
704 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
PYPI_PN=${PN/-/.}
PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
DESCRIPTION="Oslo i18n library"
HOMEPAGE="
https://opendev.org/openstack/oslo.i18n/
https://github.com/openstack/oslo.i18n/
https://pypi.org/project/oslo.i18n/
"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 ~riscv x86"
RDEPEND="
>=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
"
BDEPEND="
${RDEPEND}
test? (
>=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
>=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
)
"
distutils_enable_tests unittest