You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/shtab/shtab-1.7.1.ebuild

29 lines
576 B

# Copyright 2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1 pypi
DESCRIPTION="Automagic shell tab completion for Python CLI applications"
HOMEPAGE="
https://github.com/iterative/shtab
https://pypi.org/project/shtab/
"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 x86"
BDEPEND="dev-python/setuptools-scm[${PYTHON_USEDEP}]"
distutils_enable_tests pytest
python_test() {
# Disable pytest-cov
epytest -o addopts=
}