You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-scheme/guile-colorized/guile-colorized-0.1_p201912...

40 lines
997 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DESCRIPTION="Colorized REPL for GNU Guile"
HOMEPAGE="https://gitlab.com/NalaGinrut/guile-colorized/"
if [[ "${PV}" == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/NalaGinrut/${PN}.git"
else
# Latest release (before this commit from 2019) was in 2015
COMMIT_SHA="1625a79f0e31849ebd537e2a58793fb45678c58f"
SRC_URI="https://gitlab.com/NalaGinrut/${PN}/-/archive/${COMMIT_SHA}.tar.bz2 -> ${P}.tar.bz2"
KEYWORDS="~amd64"
S="${WORKDIR}/${PN}-${COMMIT_SHA}"
fi
LICENSE="GPL-3"
SLOT="0"
RDEPEND=">=dev-scheme/guile-2.0.9:="
DEPEND="${RDEPEND}"
src_prepare() {
default
# http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
find "${S}" -name "*.scm" -exec touch {} + || die
}
src_install() {
einstalldocs
local loadpath=$(guile -c '(display (string-append (car %load-path) "/ice-9"))')
mkdir -p "${D}${loadpath}"
emake TARGET="${D}${loadpath}" install
}