You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-scheme/guile-hall/guile-hall-0.4.1.ebuild

42 lines
920 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit autotools
DESCRIPTION="Guile tooling to create and publish projects"
HOMEPAGE="https://gitlab.com/a-sassmannshausen/guile-hall/"
SRC_URI="https://gitlab.com/a-sassmannshausen/${PN}/-/archive/${PV}/${P}.tar.bz2"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
>=dev-scheme/guile-2.0.0:=
dev-scheme/guile-config
"
DEPEND="${RDEPEND}"
# guile generates ELF files without use of C or machine code
# It's a portage's false positive. bug #677600
QA_PREBUILT='*[.]go'
src_prepare() {
default
# http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
find "${S}" -name "*.scm" -exec touch {} + || die
eautoreconf
}
src_install() {
default
# Workaround llvm-strip problem of mangling guile ELF debug
# sections: https://bugs.gentoo.org/905898
dostrip -x "/usr/$(get_libdir)/guile"
}