You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-scheme/guile-sqlite3/guile-sqlite3-0.1.3.ebuild

42 lines
896 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit autotools
DESCRIPTION="Guile bindings of sqlite3"
HOMEPAGE="https://notabug.org/guile-sqlite3/guile-sqlite3"
SRC_URI="https://notabug.org/guile-sqlite3/guile-sqlite3/archive/v${PV}.tar.gz
-> ${P}.tar.gz"
S="${WORKDIR}/${PN}"
LICENSE="LGPL-3+ GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
>=dev-scheme/guile-2.0.11:=
dev-db/sqlite:3=
"
DEPEND="${RDEPEND}"
# guile generates ELF files without use of C or machine code
# It's a portage's false positive. bug #677600
QA_PREBUILT='*[.]go'
src_prepare() {
default
# upstream tag on top of source tree. has no autogenerated files
eautoreconf
}
src_install() {
default
# Workaround llvm-strip problem of mangling guile ELF debug
# sections: https://bugs.gentoo.org/905898
dostrip -x "/usr/$(get_libdir)/guile"
}