You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-tex/glossaries/glossaries-4.52.ebuild

41 lines
945 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit latex-package
DESCRIPTION="Create glossaries and lists of acronyms"
HOMEPAGE="https://www.ctan.org/pkg/glossaries/"
SRC_URI="https://mirrors.ctan.org/macros/latex/contrib/glossaries.zip -> ${P}.zip"
LICENSE="LPPL-1.2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
IUSE="doc examples"
RDEPEND="dev-lang/perl
dev-texlive/texlive-latexrecommended
>=dev-texlive/texlive-latexextra-2012
dev-texlive/texlive-plaingeneric"
BDEPEND="${RDEPEND}
app-arch/unzip"
TEXMF="/usr/share/texmf-site"
S=${WORKDIR}/${PN}
src_install() {
latex-package_src_doinstall styles
dobin makeglossaries
dodoc CHANGES
if use doc ; then
latex-package_src_doinstall pdf
fi
if use examples ; then
docinto examples
dodoc samples/*.tex
fi
}