You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/cdecl/cdecl-14.2.ebuild

32 lines
763 B

# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DESCRIPTION='Composing and deciphering C (or C++) declarations or casts, aka "gibberish."'
HOMEPAGE="https://github.com/paul-j-lucas/cdecl"
SRC_URI="https://github.com/paul-j-lucas/cdecl/releases/download/${P}/${P}.tar.gz -> ${P}.release.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 ~arm64 ~x86"
IUSE="debug readline ncurses"
DEPEND="
ncurses? ( sys-libs/ncurses:0= )
readline? ( sys-libs/readline:0= )
"
RDEPEND="${DEPEND}"
BDEPEND="
app-alternatives/yacc
app-alternatives/lex
"
src_configure() {
econf \
$(use_with readline) \
$(use_enable ncurses term-size) \
$(use_enable debug bison-debug) \
$(use_enable debug flex-debug)
}