You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/cucumber-messages/cucumber-messages-24.0.1.eb...

25 lines
747 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
USE_RUBY="ruby31 ruby32 ruby33"
RUBY_FAKEGEM_GEMSPEC="cucumber-messages.gemspec"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_EXTRADOC="README.md"
RUBY_FAKEGEM_EXTRAINSTALL="VERSION"
inherit ruby-fakegem
DESCRIPTION="Protocol Buffer messages for Cucumber's inter-process communication"
HOMEPAGE="https://cucumber.io/"
SRC_URI="https://github.com/cucumber/messages/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
RUBY_S="messages-${PV}/ruby"
LICENSE="MIT"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
SLOT="$(ver_cut 1)"
ruby_add_bdepend "test? ( >=dev-util/cucumber-compatibility-kit-12.0 )"