You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/cwdiff/cwdiff-0.4.0.ebuild

32 lines
746 B

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
if [ "${PV}" = "9999" ]; then
EGIT_REPO_URI="https://github.com/junghans/${PN}.git"
inherit git-r3
else
SRC_URI="https://github.com/junghans/cwdiff/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x64-macos"
fi
DESCRIPTION="A script that wraps wdiff to support directories and colorize the output"
HOMEPAGE="https://github.com/junghans/cwdiff"
LICENSE="GPL-2"
SLOT="0"
IUSE="mercurial"
BDEPEND="sys-apps/help2man"
RDEPEND="
app-text/wdiff
sys-apps/diffutils
mercurial? ( dev-vcs/mercurial )
"
src_install() {
emake DESTDIR="${ED}" $(usex mercurial '' 'HGRCDIR=') install
dodoc README.md
}