You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/diff-cover/diff-cover-6.5.0-r1.ebuild

32 lines
799 B

# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=poetry
PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
DESCRIPTION="Find diff lines that do not have test coverage"
HOMEPAGE="https://github.com/Bachmann1234/diff-cover"
SRC_URI="https://github.com/Bachmann1234/diff-cover/archive/v${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${P/diff-cover/diff_cover}"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
RDEPEND="
dev-python/pygments[${PYTHON_USEDEP}]
>=dev-python/jinja-2.7.1[${PYTHON_USEDEP}]
>=dev-python/pluggy-0.13.1[${PYTHON_USEDEP}]
>=dev-python/chardet-3.0.0[${PYTHON_USEDEP}]
>=dev-python/tomli-1.2.1
"
BDEPEND="
test? (
dev-python/mock[${PYTHON_USEDEP}]
)
"
distutils_enable_tests pytest