You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/gi-docgen/gi-docgen-2023.1-r1.ebuild

39 lines
988 B

# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
DESCRIPTION="A documentation generator for GObject-based libraries"
HOMEPAGE="
https://gitlab.gnome.org/GNOME/gi-docgen
https://pypi.org/project/gi-docgen/
"
LICENSE="|| ( Apache-2.0 GPL-3+ ) CC0-1.0 OFL-1.1 MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv sparc x86"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
${PYTHON_DEPS}
$(python_gen_cond_dep '
>=dev-python/markdown-3.2[${PYTHON_USEDEP}]
>=dev-python/markupsafe-1[${PYTHON_USEDEP}]
>=dev-python/pygments-2[${PYTHON_USEDEP}]
>=dev-python/jinja-2[${PYTHON_USEDEP}]
>=dev-python/typogrify-2[${PYTHON_USEDEP}]
')
$(python_gen_cond_dep '
dev-python/tomli[${PYTHON_USEDEP}]
' 3.10)
"
distutils_enable_tests pytest