You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/howdoi/howdoi-2.0.20-r1.ebuild

29 lines
692 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517="setuptools"
PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1 pypi
DESCRIPTION="A code search tool"
HOMEPAGE="https://pypi.org/project/howdoi/"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 x86"
# bug 818580
RESTRICT="test"
RDEPEND="
dev-python/appdirs[${PYTHON_USEDEP}]
dev-python/cachelib[${PYTHON_USEDEP}]
dev-python/colorama[${PYTHON_USEDEP}]
dev-python/keep[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
>=dev-python/pyquery-1.4.1[${PYTHON_USEDEP}]
dev-python/rich[${PYTHON_USEDEP}]
>=dev-python/requests-2.24.0[${PYTHON_USEDEP}]
"