You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/lockrun/lockrun-20120508-r2.ebuild

30 lines
596 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit toolchain-funcs
DESCRIPTION="Lockrun - runs cronjobs with overrun protection"
HOMEPAGE="http://www.unixwiz.net/tools/lockrun.html"
S="${WORKDIR}"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="amd64 ~hppa x86"
src_unpack() {
cp -v "${FILESDIR}"/${PN}.c-${PV} "${S}"/${PN}.c || die
cp -v "${FILESDIR}"/${PN}.c-${PV} "${S}"/README || die
}
src_compile() {
emake CC="$(tc-getCC)" ${PN}
sed -i README -e '60q;s|^ \*||g' || die
}
src_install() {
dobin ${PN}
einstalldocs
}