You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/lxqt-build-tools/lxqt-build-tools-0.13.0.ebuild

27 lines
543 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit cmake
DESCRIPTION="LXQt Build Tools"
HOMEPAGE="https://lxqt-project.org/"
if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
else
SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
KEYWORDS="amd64 ~arm arm64 ~hppa ~loong ~ppc64 ~riscv x86"
fi
LICENSE="BSD"
SLOT="0"
DEPEND="
>=dev-libs/glib-2.50.0
>=dev-qt/qtcore-5.15:5
"
RDEPEND="${DEPEND}"