You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/packer/packer-1.8.6.ebuild

36 lines
782 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit go-module
DESCRIPTION="A tool to create identical machine images for multiple platforms"
HOMEPAGE="https://www.packer.io"
SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
https://gentoofiles.s3.eu-central-1.amazonaws.com/${P}-deps.tar.xz"
LICENSE="Apache-2.0 BSD-2 BSD-4 MIT MPL-2.0 unicode"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~riscv"
DOCS=( {README,CHANGELOG}.md )
RESTRICT+=" test"
src_compile() {
ego build \
-mod=readonly \
-ldflags "${go_ldflags}" \
-work -o "bin/${PN}" ./ || die
}
src_install() {
dobin bin/packer
einstalldocs
insinto /usr/share/zsh/site-functions
doins contrib/zsh-completion/_packer
}