You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.4.3.e...

27 lines
578 B

# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit cmake
DESCRIPTION="Bandwidth test for ROCm"
HOMEPAGE="https://github.com/RadeonOpenCompute/rocm_bandwidth_test"
SRC_URI="https://github.com/RadeonOpenCompute/${PN}/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="NCSA-AMD"
SLOT="0/$(ver_cut 1-2)"
KEYWORDS="~amd64"
DEPEND="dev-libs/rocr-runtime:="
RDEPEND="${DEPEND}"
BDEPEND=""
S="${WORKDIR}/${PN}-rocm-${PV}"
src_install() {
cmake_src_install
rm -rfv "${ED}"/usr/share/doc/rocm-bandwidth-test
}