You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/rocminfo/rocminfo-5.7.1.ebuild

39 lines
1014 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit cmake
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/RadeonOpenCompute/rocminfo/"
inherit git-r3
else
SRC_URI="https://github.com/RadeonOpenCompute/rocminfo/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
S="${WORKDIR}/rocminfo-rocm-${PV}"
fi
DESCRIPTION="ROCm Application for Reporting System Info"
HOMEPAGE="https://github.com/RadeonOpenCompute/rocminfo"
LICENSE="UoI-NCSA"
SLOT="0/$(ver_cut 1-2)"
RDEPEND=">=dev-libs/rocr-runtime-${PV}"
DEPEND="${RDEPEND}"
#PATCHES=(
# "${FILESDIR}/${PN}-5.5.1-detect-builtin-amdgpu.patch"
#)
src_prepare() {
sed -e "/CPACK_RESOURCE_FILE_LICENSE/d" -i CMakeLists.txt || die
sed -e "/num_change_since_prev_pkg(/cset(NUM_COMMITS 0)" -i cmake_modules/utils.cmake || die # Fix QA issue on "git not found"
cmake_src_prepare
}
src_configure() {
local mycmakeargs=( -DROCRTST_BLD_TYPE=Release )
cmake_src_configure
}