You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/squashmerge/squashmerge-0.1.ebuild

34 lines
715 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="dev-util/squashdelta delta merge tool"
HOMEPAGE="https://github.com/projg2/squashmerge/"
SRC_URI="https://github.com/projg2/${PN}/releases/download/v${PV}/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="lz4 +lzo"
# SquashDelta does not make much sense without a compression algo.
REQUIRED_USE="|| ( lz4 lzo )"
COMMON_DEPEND="
lz4? ( app-arch/lz4:0= )
lzo? ( dev-libs/lzo:2= )"
RDEPEND="${COMMON_DEPEND}
dev-util/xdelta:3"
DEPEND=${COMMON_DEPEND}
DOCS=( FORMAT )
src_configure() {
local myconf=(
$(use_enable lz4)
$(use_enable lzo)
)
econf "${myconf[@]}"
}