You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/sysprof-capture/sysprof-capture-3.36.0-r1.e...

37 lines
751 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
GNOME_ORG_MODULE="sysprof"
inherit gnome.org meson-multilib systemd
DESCRIPTION="Static library for sysprof capture data generation"
HOMEPAGE="http://sysprof.com/"
LICENSE="GPL-3+ GPL-2+"
SLOT="3"
KEYWORDS="amd64 ~arm64 x86"
IUSE=""
RDEPEND=">=dev-libs/glib-2.61.3:2[${MULTILIB_USEDEP}]"
DEPEND="${RDEPEND}"
BDEPEND="
dev-util/gdbus-codegen
>=sys-kernel/linux-headers-2.6.32
virtual/pkgconfig
"
multilib_src_configure() {
local emesonargs=(
-Denable_gtk=false
-Dlibsysprof=false
-Dwith_sysprofd=none
-Dsystemdunitdir=$(systemd_get_systemunitdir)
# -Ddebugdir
-Dhelp=false
-Dlibunwind=false
)
meson_src_configure
}